Resolving other dependency conflicts

Use this procedure to resolve dependency issues in which the installed versions of one or more dependencies are newer than the versions included in the Zenoss mirror. The following example shows a typical yum error of this type:
Error: Package: policycoreutils-python-2.5-9.el7.x86_64 (zenoss-mirror)
Requires: policycoreutils = 2.5-9.el7
Installed: policycoreutils-2.5-11.el7_3.x86_64 (@updates)

Follow these steps:

  1. Install the older package.
    Replace Package-Name with the name of the package displayed in the error message:
    rpm -Uvh --oldpackage Package-Name
  2. Clean all yum caches.
    yum clean all
Return to the procedure you were performing before turning to this appendix and retry the yum install command that failed previously.