Installing the OpenJDK

Analytics requires the OpenJDK 7 Development package. Analytics cannot be installed when just the JRE is installed.
Prior to installing the OpenJDK 7 Development package, you should remove all other versions of Java that are on the system:
yum -y remove $(rpm -qa | egrep -i '(jdk|jre|java)')
  1. Log in to the Analytics server as root, or as a user with superuser privileges.
  2. Install the OpenJDK 7.
    yum -y install java-1.7.0-openjdk-devel
  3. Verify that the installation succeeded.
    java -version
    If the command returns output similar to the following, continue to the next procedure. The <_version> patch version does not need to match
    java version "1.7.0_75"
    OpenJDK Runtime Environment (rhel-2.5.4.7.el7_1.x86_64 u75-b13)
    OpenJDK 64-Bit Server VM (build 24.75-b04, mixed mode)